[Gluster-devel] Smoke test question

Luis Pabon lpabon at redhat.com
Tue Apr 15 15:10:32 UTC 2014

Hi Justin,
     I did not use GlusterFS on the host system, I tried just using XFS 
and ext4 to see if it would pass posix-compliance, but the issue is that 
they do not.  My hope is that someone shows me that I am doing something 
wrong, or forgot some switch because it just seems weird that they 
cannot pass on local filesystems.

- Luis

On 04/14/2014 10:45 PM, Justin Clift wrote:
> On 15/04/2014, at 3:11 AM, Luis Pabon wrote:
>> Hi guys,
>>     I am investigating running smoke tests inside Docker.io, but I cannot seem to pass the posix-compliance tests.  I then tried to run the posix-compliance tests on XFS and EXT4 but I could make them pass there either.  This is what I did:
>> $ truncate -s 5G mydisk
>> $ sudo mkfs.xfs mydisk
>> $ sudo mount -o loop mydisk /mnt
>> $ cd /mnt
>> * Change the value of 'fs' in ~/qa/tools/posix-compliance/conf according to the file system format.
>> $ prove -r ~/qa/tools/posix-compliance/tests
>> They always fail on chown tests.  Anyone know why?
> Which OS, and which release or git repo branch of Gluster?
> If CentOS 6.5 and upstream master, then what kernel version are you
> running?  I had problems with one of the recent CentOS 6.5 kernels, but
> a subsequent update to the newest one about a week ago
> (<something>11.<something> in the name) fixed it.
> + Justin
>> - Luis
> --
> Open Source and Standards @ Red Hat
> twitter.com/realjustinclift

More information about the Gluster-devel mailing list