Re: [Gluster-devel] help getting RPMs from latest tla ( ¿1.3.8? ) PART II

Matt Paine matt at
Tue Jan 15 01:18:15 UTC 2008

Sorry, forwarding for the lists benifit (forgot that reply-all button 



Hi Angel

I havn't had time to double check the spec file yet - too busy with
looking at a new job and such :/

Have you looked at this page...


These are instructions that I use to create RPM's. I havn't tried it for
a number of months now, but they should still be alright. Please let me
know of anything that doesn't work and I'll make the time to fixup the
spec file.

As far as fuse is concerned, it might require fuse to build the rpms,
but it does not distribute fuse within the binary rpms. Also, if you
only install the glusterfs-server, it willnot require fuse to be
installed on the machines.

I have yet to even look at the spec file again to see about requiring
fuse-devel for building the rpms in the first place, but someone else
may be able to confirm that, again, i'll try and make the time in the
next few days to update the spec file a bit.

Hope this helps.


Angel wrote:

> Hi all,
> Still trying to get the rpms...
> That's what i tried:
> $ tla get -A gluster at glusterfs--mainline--2.5 glusterfs-1.3.8
> $ cd glusterfs-1.3.8
> $ ./
> $ ./configure -disable-ibverbs --disable-python (for me)
> $ make
> Compilation successfull, so now i erase all object files and prpare to make rpm...
> $make clean
> $ cd ..
> $ tar -czvf glusterfs-1.3.8.tar.gz
> $ rpmbuild -vv -ta glusterfs-1.3.8.tar.gz --without ibverbs
> error: line 5: Unknown tag: volume client1
> D: May free Score board((nil))
> Is a spec error or what? 
> standalone configure && make works well so where is the faulty piece??
> Regards, Angel

More information about the Gluster-devel mailing list