Re: [Gluster-devel] Is lock (fcntl) supported by multilple concurentclient ? gpvcs at
Thu Apr 5 21:36:38 UTC 2007

Hi Vikas!

>Also, POSIX locking support has been moved into a separate
>now (features/posix-locks). This will give us locking
support over other 
>storage backends as well (for example Amazon S3).

Thanks for the news. I was wondering if in the release 1.4
you might want to support "Samba/Windows" NonPosix mandatory
Locks (mount -o mand ..) but that's for the future.

I'm trying to use the "glusterfs" cluster from Aix. I tried
Cifs but it was unsuccessful (cannot avoid caching), so I'm
going back to the NFS vers=3 (NFS vers=4 is too instable
under linux).
And I have a specific problem with glusterfs.

When I exported the filesystem under linux FC4:
  /export/fs5 localhost(rw,fsid=1)
and mount it locally:
  mount -o vers=3 localhost:/export/fs2 nfs1
I encounter the following problem:
  (-- pts/39) touch /gfs/nfs1/essai
  (-- pts/39) ls -lrt /gfs/nfs1/essai
  -rw-r--r--  1 fturi ft 0 Apr  5 17:10 /gfs/nfs1/essai
  (-- pts/39) ls > /gfs/nfs1/essai
  ls: write error: Operation not permitted

I enabled the trace and basically I see only fuse_gattr and
fuse_gattr_cbk in the debug trace. 
I know that fuse_open is  being called (according to gdb)
and nothing else.
I have the same problem with release 1.2.3, 1.3.2pre2 and tla
I have the same problem with Linux NFS client and Aix NFS
client (in Aix the strerror says: Not owner). I also tried
different combinaison of exports (no_root_squash .. anon_uid
...) and users and always get the same result.

I suspect something that the NFS deamon doesnt like in the
attributes returned or a problem in open.

Do you have any hint what and where I could check to debug
this behavior ?

Happy Easter, FT

------------------------ ALICE C'EST ENCORE MIEUX AVEC CANAL+ LE BOUQUET ! ---------------
Découvrez vite l'offre exclusive ALICEBOX et CANAL+ LE BOUQUET, en cliquant ici
Soumis à conditions.

More information about the Gluster-devel mailing list