[Bugs] [Bug 1730433] New: Gluster release 6 build errors on ppc64le

bugzilla at redhat.com bugzilla at redhat.com
Tue Jul 16 17:35:41 UTC 2019


            Bug ID: 1730433
           Summary: Gluster release 6 build errors on ppc64le
           Product: GlusterFS
           Version: 6
          Hardware: ppc64le
                OS: Linux
            Status: NEW
         Component: libglusterfsclient
          Assignee: bugs at gluster.org
          Reporter: robbaron at bu.edu
                CC: bugs at gluster.org
  Target Milestone: ---
    Classification: Community

Description of problem:

I only selected a component because of Bugzilla's limitation.  not sure which
component glusterfs is.

When building glusterfs on RHEL7 (ppc64le) I had to the following errors:

1) In the glusterfs director, if I use ./configure without any options, I get
the following error when I build it:

    rpcsvc.c: In function 'rpcsvc_callback_build_record':
    rpcsvc.c:1197:5: error: implicit declaration of function 'xdr_sizeof' [-
        xdr_size = xdr_sizeof((xdrproc_t)xdr_callmsg, &request); 

This can be worked around by using the following:

    ./configure --with-ipv6-default

It seems to that if you have the option, then it should work with or without
the option.

2) On 2 of the three systems I compiled release-6 of gluster I had the
following issue:

      CCLD     cloudsyncs3.la
      .libs/libcloudsyncs3.o: In function `aws_sign_request':
undefined reference to `HMAC_CTX_new'
undefined reference to `HMAC_CTX_free'
         collect2: error: ld returned 1 exit status

This seems to be defined in libssl/libcrypt.  Since I built openssl, I check
that that pig-config was returning the correct information.

I wound up editing the following Makefile:


and changing:

    CFLAGS = -g -O2 


    CFLAGS = -g -O2 -lssl -lcrypt -I/usr/local/include/openssl/

Which resolved the linker error.

How reproducible:

The first problem happened on all three systems.  The second problem happened
on 2 of the three systems, so is probably less reproducible.

Here is the sequence of commands I ran on each of the systems

yum groupinstall -y "Development Tools"
yum install -y python3
yum install -y libtool perl-core zlib-devel -y
yum install -y autoconf automake bison cmockery2-devel dos2unix flex fuse-devel
glib2-devel libacl-devel libaio-devel libattr-devel libcurl-devel
libibverbs-devel librdmacm-devel libtirpc-devel libtool libxml2-devel
lvm2-devel make openssl-devel pkgconfig pyliblzma python-devel python-eventlet
python-netifaces python-paste-deploy python-simplejson python-sphinx
python-webob pyxattr readline-devel rpm-build sqlite-devel systemtap-sdt-devel
tar userspace-rcu-devel
yum install -y libuuid libuuid-devel libacl1 libacl libacl-devel libxml2
yum install -y libibverbs libibverbs-devel readline readline-devel
yum install -y libaio libaio-devel

yum install -y rh-python36.ppc64le

# - OpenSSL
cd /home/robbaron
git clone https://github.com/openssl/openssl.git
cd openssl/
git fetch --all
git checkout OpenSSL_1_1_1-stable
make test
make install
cd ..

# - userspace rcu
cd /home/robbaron
git clone git://git.liburcu.org/userspace-rcu.git
cd userspace-rcu/
git fetch --all
git checkout stable-0.11
make check
make install

# copy the pc files so that pig-config can find them
cp /usr/local/lib/pkgconfig/* /usr/lib64/pkgconfig

# - GlusterFS
cd /home/robbaron
git clone https://github.com/gluster/glusterfs.git
cd glusterfs
git fetch --all
git checkout release-6
./configure --with-ipv6-default
make check
make install
cd ..

systemctl start glusterd
systectl status glusterd
systemctl status glusterd

You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

More information about the Bugs mailing list