[Bugs] [Bug 1743215] glusterd-utils: 0-management: xfs_info exited with non-zero exit status [Permission denied]

bugzilla at redhat.com bugzilla at redhat.com
Wed Aug 28 13:48:05 UTC 2019


Jóhann B. Guðmundsson <johannbg at gmail.com> changed:

           What    |Removed                     |Added
              Flags|needinfo?(johannbg at gmail.co |
                   |m)                          |

--- Comment #2 from Jóhann B. Guðmundsson <johannbg at gmail.com> ---
There is no such thing as xfs_prog in Fedora so presumably you just meant
xfs_info which triggers this error if not you probably need to ping Eric.

# gluster volume info

Volume Name: virt01
Type: Replicate
Volume ID: <zanitized>
Status: Started
Snapshot Count: 0
Number of Bricks: 1 x 3 = 3
Transport-type: tcp
Brick1: <zanitized>:/srv/glusterfs/images
Brick2: <zanitized>:/srv/glusterfs/images
Brick3: <zanitized>:/srv/glusterfs/images
Options Reconfigured:
performance.client-io-threads: off
nfs.disable: on
transport.address-family: inet
server.allow-insecure: on

The glusterfs mount point is the same on all hosts

localhost:/virt01                      7.3T  149G  7.2T   2%

If I run it against the mapped device 
# xfs_info /dev/mapper/ht_gluster01-lv_gluster01
xfs_info: /dev/mapper/ht_gluster01-lv_gluster01 contains a mounted filesystem

fatal error -- couldn't initialize XFS library

If I run it against the mapped mount point for the device ( /srv/glusterfs/ ) 
# xfs_info /srv/glusterfs/
meta-data=/dev/mapper/ht_gluster01-lv_gluster01 isize=512    agcount=32,
agsize=61047296 blks
         =                       sectsz=512   attr=2, projid32bit=1
         =                       crc=1        finobt=1, sparse=1, rmapbt=0
         =                       reflink=0
data     =                       bsize=4096   blocks=1953513472, imaxpct=5
         =                       sunit=32     swidth=320 blks
naming   =version 2              bsize=8192   ascii-ci=0, ftype=1
log      =internal log           bsize=4096   blocks=521728, version=2
         =                       sectsz=512   sunit=0 blks, lazy-count=1
realtime =none                   extsz=4096   blocks=0, rtextents=0

If I run it against the Brick path which is a directory called images and
resides under /srv/glusterfs/ xfs mount point  ( /srv/glusterfs/images )
xfs_info /srv/glusterfs/images
/srv/glusterfs/images: Not a XFS mount point.

Note that none of the error msg xfs_info provided are permissions error

You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

More information about the Bugs mailing list