[Bugs] [Bug 1193929] GlusterFS can be improved
bugzilla at redhat.com
bugzilla at redhat.com
Tue Sep 4 04:58:56 UTC 2018
https://bugzilla.redhat.com/show_bug.cgi?id=1193929
--- Comment #319 from Worker Ant <bugzilla-bot at gluster.org> ---
COMMIT: https://review.gluster.org/20834 committed in master by "Amar Tumballi"
<amarts at redhat.com> with a commit message- multiple files: calloc -> malloc
xlators/cluster/stripe/src/stripe-helpers.c: Move to GF_MALLOC() instead of
GF_CALLOC() when possible
xlators/cluster/dht/src/tier.c: Move to GF_MALLOC() instead of GF_CALLOC() when
possible
xlators/cluster/dht/src/dht-layout.c: Move to GF_MALLOC() instead of
GF_CALLOC() when possible
xlators/cluster/dht/src/dht-helper.c: Move to GF_MALLOC() instead of
GF_CALLOC() when possible
xlators/cluster/dht/src/dht-common.c: Move to GF_MALLOC() instead of
GF_CALLOC() when possible
xlators/cluster/afr/src/afr.c: Move to GF_MALLOC() instead of GF_CALLOC() when
possible
xlators/cluster/afr/src/afr-inode-read.c: Move to GF_MALLOC() instead of
GF_CALLOC() when possible
tests/bugs/replicate/bug-1250170-fsync.c: Move to GF_MALLOC() instead of
GF_CALLOC() when possible
tests/basic/gfapi/gfapi-async-calls-test.c: Move to GF_MALLOC() instead of
GF_CALLOC() when possible
tests/basic/ec/ec-fast-fgetxattr.c: Move to GF_MALLOC() instead of GF_CALLOC()
when possible
rpc/xdr/src/glusterfs3.h: Move to GF_MALLOC() instead of GF_CALLOC() when
possible
rpc/rpc-transport/socket/src/socket.c: Move to GF_MALLOC() instead of
GF_CALLOC() when possible
rpc/rpc-lib/src/rpc-clnt.c: Move to GF_MALLOC() instead of GF_CALLOC() when
possible
extras/geo-rep/gsync-sync-gfid.c: Move to GF_MALLOC() instead of GF_CALLOC()
when possible
cli/src/cli-xml-output.c: Move to GF_MALLOC() instead of GF_CALLOC() when
possible
cli/src/cli-rpc-ops.c: Move to GF_MALLOC() instead of GF_CALLOC() when possible
cli/src/cli-cmd-volume.c: Move to GF_MALLOC() instead of GF_CALLOC() when
possible
cli/src/cli-cmd-system.c: Move to GF_MALLOC() instead of GF_CALLOC() when
possible
cli/src/cli-cmd-snapshot.c: Move to GF_MALLOC() instead of GF_CALLOC() when
possible
cli/src/cli-cmd-peer.c: Move to GF_MALLOC() instead of GF_CALLOC() when
possible
cli/src/cli-cmd-global.c: Move to GF_MALLOC() instead of GF_CALLOC() when
possible
It doesn't make sense to calloc (allocate and clear) memory
when the code right away fills that memory with data.
It may be optimized by the compiler, or have a microscopic
performance improvement.
In some cases, also changed allocation size to be sizeof some
struct or type instead of a pointer - easier to read.
In some cases, removed redundant strlen() calls by saving the result
into a variable.
1. Only done for the straightforward cases. There's room for improvement.
2. Please review carefully, especially for string allocation, with the
terminating NULL string.
Only compile-tested!
updates: bz#1193929
Original-Author: Yaniv Kaul <ykaul at redhat.com>
Signed-off-by: Yaniv Kaul <ykaul at redhat.com>
Signed-off-by: Amar Tumballi <amarts at redhat.com>
Change-Id: I16274dca4078a1d06ae09a0daf027d734b631ac2
--
You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.
More information about the Bugs
mailing list