[Bugs] [Bug 1197631] New: glusterd crashed after peer probe

bugzilla at redhat.com bugzilla at redhat.com
Mon Mar 2 09:25:12 UTC 2015


            Bug ID: 1197631
           Summary: glusterd crashed after peer probe
           Product: GlusterFS
           Version: mainline
         Component: glusterd
          Assignee: bugs at gluster.org
          Reporter: byarlaga at redhat.com
                CC: bugs at gluster.org, gluster-bugs at redhat.com

Created attachment 997003
  --> https://bugzilla.redhat.com/attachment.cgi?id=997003&action=edit
corefile of the crashed machine

Description of problem:
glusterd crashed after a peer probe. Steps that i followed :
1. Removed all the existing gluster packages using yum
2. Installed with "yum localinstall" the packages which are downloaded from:
3. Tried to create a disperse 1x(8+4) volume and gave out error message that
host is not connected
4. Then peer probed the partner and peer status.
5. started the glusterd and then peer status
6. volume create with force option and is successful

Version-Release number of selected component (if applicable):
[root at vertigo /]# gluster --version
glusterfs 3.7dev built on Mar  1 2015 01:03:38
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
You may redistribute copies of GlusterFS under the terms of the GNU General
Public License.
[root at vertigo /]# 

How reproducible:
Tried only once

Steps to Reproduce:
As mentioned in the description

Actual results:
Glusterd crashed

Expected results:
No crash should be seen

Additional info:

Attaching the crash file and sosreports of both nodes.

You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

More information about the Bugs mailing list