[automated-testing] Usage of Function name in ib_utils
Vijay Bhaskar Reddy Avuthu
vavuthu at redhat.com
Tue Jun 5 10:18:03 UTC 2018
It looks like there is a confusion of using function name for firewall
library : *glustolibs-gluster/glustolibs/gluster/lib_utils.py *
1) def *open_firewall*(nodes, firewall_service, permanent=False): --->
since above function will disable the services, In my opinion its better to
change the name to disable_firewall or remove_services_from_firewall
2) def *enable_firewall*(nodes, firewall_service, permanent=False): ---->
Above function will enable the services, its better to have the same name
enable_firewall or add_services_to_firwall
Any thoughts or suggestions ?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the automated-testing