[GEDI] [PATCH v3 04/25] error: auto propagated local_err
vsementsov at virtuozzo.com
Mon Sep 30 15:19:12 UTC 2019
30.09.2019 18:12, Kevin Wolf wrote:
> Am 24.09.2019 um 22:08 hat Vladimir Sementsov-Ogievskiy geschrieben:
>> Here is introduced ERRP_FUNCTION_BEGIN macro, to be used at start of
>> functions with errp parameter.
> A bit of bike shedding, but FOO_BEGIN suggests to me that a FOO_END will
> follow. Can we find a different name, especially now that we won't use
> this macro in every function that uses an errp, so even the "errp
> function" part isn't really correct any more?
> How about ERRP_AUTO_PROPAGATE?
I have an idea that with this macro we can (optionally) get the whole call stack
of the error and print it to log, so it's good to give it more generic name, not
limited to propagation..
or what do you think?
More information about the integration