[GEDI] [RFC v2 3/9] errp: rename errp to errp_in where it is IN-argument
eblake at redhat.com
Mon Sep 23 18:35:51 UTC 2019
On 9/23/19 11:12 AM, Vladimir Sementsov-Ogievskiy wrote:
> Error **errp is almost always OUT-argument: it's assumed to be NULL, or
> pointer to NULL-initialized pointer, or pointer to error_abort or
> error_fatal, for callee to report error.
> But very few functions (most of the are error API) instead get Error
> **errp as IN-argument: it's assumed to be set, and callee should clean
> it. In such cases, rename errp to errp_in.
> Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov at virtuozzo.com>
> include/monitor/hmp.h | 2 +-
> include/qapi/error.h | 8 ++++----
> ui/vnc.h | 2 +-
> monitor/hmp-cmds.c | 8 ++++----
> ui/vnc.c | 10 +++++-----
> util/error.c | 2 +-
> 6 files changed, 16 insertions(+), 16 deletions(-)
This is worthwhile, regardless of the fate of the rest of the series.
Reviewed-by: Eric Blake <eblake at redhat.com>
Eric Blake, Principal Software Engineer
Red Hat, Inc. +1-919-301-3226
Virtualization: qemu.org | libvirt.org
More information about the integration