<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
</head>
<body bgcolor="#ffffff" text="#1e1e1e" link="#b453b0" vlink="#8a4887" style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">
<div>Ive installed glusterfs successfully and set up the ctdb module to work with it.</div>
<div>When creating a new glusterfs volume glusterfs writes to smb.conf to create a share automatically, the share does not work &quot;Unable to mount location&quot;.&nbsp;</div>
<div>I successfully created a share pointing to the gluster mount point see below, but i cant get the HA feature to work.</div>
<div><br>
</div>
<div><br>
</div>
<div>This works!</div>
<blockquote type="cite">
<div>[csmb]</div>
<div>comment = Clustered Samba</div>
<div>public = yes</div>
<div>path = /share/</div>
<div>writeable = yes</div>
<div>ea support = yes</div>
</blockquote>
<div><br>
</div>
<div>And this does not.</div>
<div><br>
</div>
<div>[gluster-share]</div>
<div>comment = share</div>
<div>vfs objects = glusterfs</div>
<div>glusterfs:volume = share</div>
<div>glusterfs:logfile = /var/log/samba/glusterfs-share.%M.log</div>
<div>glusterfs:loglevel = 7</div>
<div>path = /</div>
<div>read only = no</div>
<div>guest ok = yes</div>
<div><br>
</div>
<div>I used 3 nodes with a replicated glusterfs share to test this.</div>
<div>So i have 2 issues i need solved.</div>
<div>1. the config that glusterfs writes to smb.conf doesnt work why?</div>
<div>2. when one of the nodes shutsdown while a client writes to a ctdb share it stops completely and the client cant write to the share anymore. How do i get around this?&nbsp;</div>
<div>The other nodes should take over so the client can be able to write to the share when a node goes down.</div>
<div><br>
</div>
<div>The ctdb config:</div>
<div>&nbsp;nodes:</div>
<div>192.168.1.10</div>
<div>192.168.1.11</div>
<div>192.168.1.13</div>
<div><br>
</div>
<div>public_addresses:</div>
<div>192.168.1.212/24 eth1</div>
<div><br>
</div>
<div>ctdb:</div>
<div>CTDB_RECOVERY_LOCK=/opt/samba-config/lockfile</div>
<div>CTDB_PUBLIC_ADDRESSES=/opt/samba-config/public_addresses</div>
<div>CTDB_MANAGES_SAMBA=yes</div>
<div>CTDB_MANAGES_WINBIND=yes</div>
<div>CTDB_LOGFILE=/var/log/log.ctdb</div>
<div>CTDB_SYSLOG=no</div>
<div><br>
</div>
<div><br>
</div>
<div>Overall im having a hard time to make ctdb work properly, i would appreciate other peoples insight and thoughts around ctdb. To me it doesnt realy feel like a stable product.</div>
<div>Would you advice me to use ctdb in an environment that's in production?</div>
<div><br>
</div>
<div>Best regards&nbsp;</div>
<div>&nbsp;</div>
<div><span>
<pre>-- 

Daniel Filipazzi&nbsp;
Division of Oncology&nbsp;
Department of Clinical Sciences, Lund&nbsp;
Lund University Cancer Center/Medicon Village&nbsp;
Building 404:B3 Scheelev├Ągen 2&nbsp;
SE-223 81 Lund&nbsp;
Sweden&nbsp;

Email: Daniel.filipazzi@med.lu.se</pre>
</span></div>
</body>
</html>