[Gluster-users] How to replace a brick in a dispersed volume?

Thomas Pries thomas-pries at web.de
Tue Feb 20 07:13:09 UTC 2024


I setup a 4+2 dispersed volume and it worked well so far.

     gluster volume info
     Volume Name: disperseVol
     Type: Disperse
     Volume ID: 35386b55-829c-4bac-bdba-609427269cf4
     Status: Started
     Snapshot Count: 0
     Number of Bricks: 1 x (4 + 2) = 6
     Transport-type: tcp
     Options Reconfigured:
     nfs.disable: on
     transport.address-family: inet
     storage.fips-mode-rchecksum: on
     features.bitrot: on
     features.scrub: Active

Now two host (.130.4, .130.3) burned down an the two bricks are gone.
The volume works still well, but I'm unable to replace the vanished
bricks to get back redundancy. I followed the gluster docs, added a new
peer and tried:

     gluster volume replace-brick disperseVol \ \ commit force

but this gives an error

     volume replace-brick: failed: Pre Validation failed on \

       brick: does not exist in
volume: disperseVol

so I got no idea how to continue (except: shred it all, start from
scratch and restore backup, but there must be a better solution).

Thanks in advance

More information about the Gluster-users mailing list