[Gluster-users] Trouble in create session in geo-rep environment

Gilberto Nunes gilberto.nunes32 at gmail.com
Thu Oct 22 13:38:45 UTC 2020


I have used as a guide this doc

Everything is ok until I tried to create a session with the command:
gluster volume geo-replication storage geoaccount at gluster-bkp::storage
create push-pem

It's return to me the following

gluster command not found on gluster-bkp for user geoaccount.
geo-replication command failed

I can do ssh to gluster-bkp passwordless.
In fact, as I am using Debian 10, I have noticed that gluster command was
not in the normal PATH. So I edit .bashrc and add
export PATH=$PATH:/usr/sbin/
So when I do ssh to the gluster-bkp I can execute the gluster command.
ssh geoaccount at gluster-bkp gluster help
peer help                - display help for peer commands
volume help              - display help for volume commands
volume bitrot help       - display help for volume bitrot commands
volume quota help        - display help for volume quota commands
snapshot help            - display help for snapshot commands
global help              - list global commands

I tried to search some in google but no luck...

Thanks for any help.

Gilberto Nunes Ferreira
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gluster.org/pipermail/gluster-users/attachments/20201022/1243a786/attachment.html>

More information about the Gluster-users mailing list