[Gluster-users] Upgrade from 6.9 to 7.7 stuck (peer is rejected)

Nikhil Ladha nladha at redhat.com
Mon Aug 24 09:14:39 UTC 2020

Hello Mabi

You don't need to follow the offline upgrade procedure. Please do follow
the online upgrade procedure only. Upgrade the nodes one by one, you will
notice the `Peer Rejected` state, after upgrading one node or so, but once
all the nodes are upgraded it will be back to `Peer in
Cluster(Connected)`.  Also, if any of the shd's are not online you can try
restarting that node to fix that. I have tried this on my own setup so I am
pretty sure, it should work for you as well.
This is the workaround for the time being so that you are able to upgrade,
we are working on the issue to come up with a fix for it ASAP.

And, yes if you face any issues even after upgrading all the nodes to 7.7,
you will be able to downgrade in back to 6.9, which I think you have
already tried and it works as per your previous mail.

Nikhil Ladha
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gluster.org/pipermail/gluster-users/attachments/20200824/cb10f42b/attachment.html>

More information about the Gluster-users mailing list