[Gluster-users] Wrong directory quota usage

Strahil Nikolov hunter86_bg at yahoo.com
Fri Aug 14 09:16:44 UTC 2020

Hi João,

Based on your output it seems that the quota size is different on the 2 bricks.

Have you tried to remove the quota and then recreate it ? Maybe it will be the easiest way  to fix it.

Best Regards,
Strahil Nikolov

На 14 август 2020 г. 4:35:14 GMT+03:00, "João Baúto" <joao.bauto at neuro.fchampalimaud.org> написа:
>Hi all,
>We have a 4-node distributed cluster with 2 bricks per node running
>7.7 + ZFS. We use directory quota to limit the space used by our
>members on
>each project. Two days ago we noticed inconsistent space used reported
>Gluster in the quota list.
>A small snippet of gluster volume quota vol list,
> Path                   Hard-limit  Soft-limit          Used
>Available         Soft-limit exceeded?   Hard-limit exceeded?
>/projectA              5.0TB        80%(4.0TB)    3.1TB           1.9TB
>         No                               No
>*/projectB            100.0TB    80%(80.0TB)  16383.4PB   740.9TB
> No                               No*
>/projectC              70.0TB     80%(56.0TB)   50.0TB         20.0TB
>     No                              No
>The total space available in the cluster is 360TB, the quota for
>is 100TB and, as you can see, its reporting 16383.4PB used and 740TB
>available (already decreased from 750TB).
>There was an issue in Gluster 3.x related to the wrong directory quota
> and
>but it's marked as solved (not sure if the solution still applies).
>*On projectB*
># getfattr -d -m . -e hex projectB
># file: projectB
>*On projectA*
># getfattr -d -m . -e hex projectA
># file: projectA
>Any idea on what's happening and how to fix it?
>*João Baúto*
>*Scientific Computing and Software Platform*
>Champalimaud Research
>Champalimaud Center for the Unknown
>Av. Brasília, Doca de Pedrouços
>1400-038 Lisbon, Portugal
>fchampalimaud.org <https://www.fchampalimaud.org/>

More information about the Gluster-users mailing list