[Gluster-users] geo-replication create push-pem command failure

Stalker, Tim Tim.Stalker at ucdenver.edu
Thu May 2 19:09:07 UTC 2019

I'm running gluster 4.1.8 on a two node replicated cluster. I'm trying to get geo-replication setup between one slave node with a running volume on it. Everything is working, I have a passwordless connection between a geogrp user on the slave and the root user on master 1.

When I run gluster volume geo-replication mastervol slavevolumemngr at slave1::slavevol create push-pem

I get this error: gluster command on slavevolumemngr at slave1 failed. Error: bash: gluster: command not found

I have passwordless login setup from the root user on master1's pub key and the key here /var/lib/glusterd/geo-replication/secret.pem.pub

Is there a logfile for the attempt to run create push-pem? ssh is setup correctly. On master1 I've tried both of these commands then the create push-pem command

gluster-georep-sshkey generate --no-prefix

gluster-georep-sshkey generate

Any help anyone can provide would be great


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gluster.org/pipermail/gluster-users/attachments/20190502/f224419a/attachment-0001.html>

More information about the Gluster-users mailing list