[Gluster-users] VMs blocked for more than 120 seconds

lemonnierk at ulrar.net lemonnierk at ulrar.net
Mon May 13 06:55:48 UTC 2019

On Mon, May 13, 2019 at 08:47:45AM +0200, Martin Toth wrote:
> Hi all,


> I am running replica 3 on SSDs with 10G networking, everything works OK but VMs stored in Gluster volume occasionally freeze with “Task XY blocked for more than 120 seconds”.
> Only solution is to poweroff (hard) VM and than boot it up again. I am unable to SSH and also login with console, its stuck probably on some disk operation. No error/warning logs or messages are store in VMs logs.

As far as I know this should be unrelated, I get this during heals
without any freezes, it just means the storage is slow I think.

> KVM/Libvirt(qemu) using libgfapi and fuse mount to access VM disks on replica volume. Can someone advice  how to debug this problem or what can cause these issues? 
> It’s really annoying, I’ve tried to google everything but nothing came up. I’ve tried changing virtio-scsi-pci to virtio-blk-pci disk drivers, but its not related.

Any chance your gluster goes readonly ? Have you checked your gluster
logs to see if maybe they lose each other some times ?

For libgfapi accesses you'd have it's log on qemu's standard output,
that might contain the actual error at the time of the freez.

More information about the Gluster-users mailing list