[Gluster-users] Volume stuck unable to add a brick

Boris Goldowsky bgoldowsky at cast.org
Thu Apr 11 17:51:46 UTC 2019

I’ve got a replicated volume with three bricks  (“1x3=3”), the idea is to have a common set of files that are locally available on all the machines (Scientific Linux 7, which is essentially CentOS 7) in a cluster.

I tried to add on a fourth machine, so used a command like this:

sudo gluster volume add-brick dockervols replica 4 webserver8:/data/gluster/dockervols force

but the result is:

volume add-brick: failed: Commit failed on webserver1. Please check log file for details.

Commit failed on webserver8. Please check log file for details.

Commit failed on webserver11. Please check log file for details.

Tried: removing the new brick (this also fails) and trying again.
Tried: checking the logs. The log files are not enlightening to me – I don’t know what’s normal and what’s not.
Tried: deleting the brick directory from previous attempt, so that it’s not in the way.
Tried: restarting gluster services
Tried: rebooting
Tried: setting up a new volume, replicated to all four machines. This works, so I’m assuming it’s not a networking issue.  But still fails with this existing volume that has the critical data in it.

Running out of ideas. Any suggestions?  Thank you!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gluster.org/pipermail/gluster-users/attachments/20190411/d8154bec/attachment.html>

More information about the Gluster-users mailing list