[Gluster-users] Error while setting cluster.granular-entry-heal

Andrea Fogazzi foggy at fogazzi.com
Thu Feb 16 18:15:56 UTC 2017

thanks for your reply; I attach the heal logs.

I have to inform that at the end  I was able to enable  cluster.granular-entry-heal parameter; we had to perform two separate actions:
1. upgrade clients on every volume: in fact upgrading to 3.8.x the clients connecting the specific volume were not sufficient, and we needed to upgrade older clients even if they are connecting to other volumes on the same gluster cluster
2. to set the cluster.granular-entry-heal parameter parameter for the volume, we had to use the syntax suggested in the error message for "gluster volume set volname parameter on" command: "(gluster volume heal vol-cor-homes  granular-entry-heal enable"; this command ended to enable the parameter, but I didn't find specific documentation other than the error message.

Regarding the attached logs: you will find that split brain prevented us to enable the parameter: yes, I was aware of that, in fact we had solved the split brain before testing to enable the parameter, but this unique action did not solved and we had also to apply 1. and 2. actions.

Thanks for your help.
Kind regards,


Andrea Fogazzi
From: Krutika Dhananjay <kdhananj at redhat.com>
Sent: Thursday, February 16, 2017 11:17 AM
To: Andrea Fogazzi
Cc: gluster-users at gluster.org
Subject: Re: [Gluster-users] Error while setting cluster.granular-entry-heal

Could you please attach the "glfsheal-<volname>.log" logfile?


On Thu, Feb 16, 2017 at 12:05 AM, Andrea Fogazzi <foggy at fogazzi.com<mailto:foggy at fogazzi.com>> wrote:


I have a gluster volume on 3.8.8 which has multiple volumes, each on distributed/replicated on 5 servers (2 replicas+1 quorum); each volume is both accessed as gluster client (RW, clients have 3.8.8 or 3.8.5) or Ganesha FS (RO).

On one of the  volumes we have:

- cluster.data-self-heal-algorithm: full
- cluster.locking-scheme: granular

When we try to set

- cluster.granular-entry-heal on

(command I use is "gluster volume set vol-cor-homes cluster.granular-entry-heal on")

I receive

volume set: failed:  'gluster volume set <VOLNAME> cluster.granular-entry-heal {enable, disable}' is not supported. Use 'gluster volume heal <VOLNAME> granular-entry-heal {enable, disable}' instead.

Answer is not clear to me; I also tried command suggested in the command response, but it does not work (I get "Enable granular entry heal on volume vol-cor-homes has been unsuccessful on bricks that are down. Please check if all brick processes are running." while I am sure all bricks are online).

Do you have any suggestion on what I am doing wrong, or how to debug the issue?

Thanks in advance.

Best regards



Andrea Fogazzi
foggy at fogazzi.com<mailto:foggy at fogazzi.com>

Gluster-users mailing list
Gluster-users at gluster.org<mailto:Gluster-users at gluster.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gluster.org/pipermail/gluster-users/attachments/20170216/434252af/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gfs-heal.zip
Type: application/x-zip-compressed
Size: 3795 bytes
Desc: gfs-heal.zip
URL: <http://lists.gluster.org/pipermail/gluster-users/attachments/20170216/434252af/attachment.bin>

More information about the Gluster-users mailing list