[Gluster-users] IPv4 / IPv6 doesn't work

Benedikt Schindler benedikt.schindler at owayo.com
Thu Feb 9 10:37:34 UTC 2017


i have two servers. Both are IPv4 and IPv6 capable.
I installed  everything with the defautl values. Creating the cluster worked
Also creating and starting the volume. 

Now, i try to mount the volume. And the mounting fails because the mount
command tries to connect via IPv6.
But GlusterFS is only listening on IPv4. 

So I tried to add this line to glusterd.vol 
"option transport.address-family inet6"

After that glusterd only listens on IPv6 but it doesn't listen anymore on
But I still have IPv4 only clients that need to mount the volume. 

So, I dind't find any documentation on the glusterd.vol file.  
(I only found a mail in the maillingslist from the year 2014 who requested a
I tried to put something in it like   "option transport.address-family inet
inet6" , but then the server didn't start.

So here are my two questions:

1) Is there a way to listen on IPv4 and IPv6 connections?  (I mean it is
2) Could I tell the mount.glusterfs command to use IPv4 ?  

Oh, sorry almost forgot:

OS: OpenSuSe Tumbleweed
Kernel:  4.9.7-1-default
GlusterFS: 3.9.1-100.1   

Best regards 
Benedikt Schindler

More information about the Gluster-users mailing list