[Gluster-users] 'ERROR: parsing the volfile failed' on fresh install

Atin Mukherjee amukherj at redhat.com
Fri Dec 15 09:49:47 UTC 2017

glusterd.vol file is default installed with glusterfs package. So I'm not
sure how did you end up into a state where this file was missing (as per my
initial investigation looking at the logs). What you could do to check if
this file is really missing or not by running "find / -iname glusterd.vol"
and if it's indeed missing then copy it from one of the peer node and
restart glusterd.

On Wed, Dec 13, 2017 at 8:01 PM, Ben Mabey <ben.mabey at recursionpharma.com>

> The tutorial doesn’t mention anything about installing that manually.
> Could you point me to some documentation on where that file would live and
> how I would go about creating one? Reinstalling the packages doesn’t seem
> to help. When I first tried to start the gluster service on this node I
> forgot to use `sudo`. Ever since then I can’t get it to start (even with
> sudo). So I think trying to start it as a regular user did something odd
> and reinstalling the packages doesn’t correct the state for some reason.
> On Dec 13, 2017, at 4:34 AM, Atin Mukherjee <amukherj at redhat.com> wrote:
> Seems like you don't have the glusterd.vol file installed in the node. Can
> you please cross check?
> On Wed, Dec 13, 2017 at 8:52 AM, Ben Mabey <ben.mabey at recursionpharma.com>
> wrote:
>> Hi all,
>> I’m trying out gluster by following the Quick Start guide on two fresh
>> installs of Ubuntu 16.04. One one node I was able to install and start
>> gluster just fine. One the other node I am running into the following:
>> $ sudo service glusterd start
>> Job for glusterd.service failed because the control process exited with
>> error code. See "systemctl status glusterd.service" and "journalctl -xe"
>> for details.
>> $ sudo journalctl -xe | tail
>> -- Unit glusterd.service has begun starting up.
>> Dec 12 20:17:46 u101410 GlusterFS[29360]: [glusterfsd.c:2004:parse_cmdline]
>> 0-glusterfs: ERROR: parsing the volfile failed [No such file or directory]
>> Dec 12 20:17:46 u101410 glusterd[29360]: USAGE: /usr/sbin/glusterd
>> [options] [mountpoint]
>> Dec 12 20:17:46 u101410 systemd[1]: glusterd.service: Control process
>> exited, code=exited status=255
>> Dec 12 20:17:46 u101410 systemd[1]: Failed to start GlusterFS, a
>> clustered file-system server.
>> -- Subject: Unit glusterd.service has failed
>> -- Defined-By: systemd
>> -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
>> --
>> -- Unit glusterd.service has failed.
>> I wasn’t able to find much information regarding this error. I have tried
>> removing gluster (via sudo apt autoremove glusterfs-server) and
>> reinstalling but that did not help.
>> Any ideas on what to try?
>> Thanks,
>> Ben
>> _______________________________________________
>> Gluster-users mailing list
>> Gluster-users at gluster.org
>> http://lists.gluster.org/mailman/listinfo/gluster-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gluster.org/pipermail/gluster-users/attachments/20171215/eb4d33da/attachment.html>

More information about the Gluster-users mailing list