[Gluster-users] How to delete geo-replication session?

mabi mabi at protonmail.ch
Tue Aug 8 06:38:52 UTC 2017

When I run the "gluster volume geo-replication status" I see my geo replication session correctly including the volume name under the "VOL" column. I see my two nodes (node1 and node2) but not arbiternode as I have added it later after setting up geo-replication. For more details have a quick look at my previous post here:
Sorry for repeating myself but again: how can I manually delete this problematic geo-replication session?
It seems to me that when I added the arbiternode it broke geo-replication.
Alternatively how can I fix this situation? but I think the easiest would be to delete the geo replication session.

> -------- Original Message --------
> Subject: Re: [Gluster-users] How to delete geo-replication session?
> Local Time: August 8, 2017 7:19 AM
> UTC Time: August 8, 2017 5:19 AM
> From: avishwan at redhat.com
> To: mabi <mabi at protonmail.ch>, Gluster Users <gluster-users at gluster.org>
> Do you see any session listed when Geo-replication status command is run(without any volume name)
> gluster volume geo-replication status
> Volume stop force should work even if Geo-replication session exists. From the error it looks like node "arbiternode.domain.tld" in Master cluster is down or not reachable.
> regards
> Aravinda VK
> On 08/07/2017 10:01 PM, mabi wrote:
>> Hi,
>> I would really like to get rid of this geo-replication session as I am stuck with it right now. For example I can't even stop my volume as it complains about that geo-replcation...
>> Can someone let me know how I can delete it?
>> Thanks
>>> -------- Original Message --------
>>> Subject: How to delete geo-replication session?
>>> Local Time: August 1, 2017 12:15 PM
>>> UTC Time: August 1, 2017 10:15 AM
>>> From: mabi at protonmail.ch
>>> To: Gluster Users [<gluster-users at gluster.org>](mailto:gluster-users at gluster.org)
>>> Hi,
>>> I would like to delete a geo-replication session on my GluterFS 3.8.11 replicat 2 volume in order to re-create it. Unfortunately the "delete" command does not work as you can see below:
>>> $ sudo gluster volume geo-replication myvolume gfs1geo.domain.tld::myvolume-geo delete
>>> Staging failed on arbiternode.domain.tld. Error: Geo-replication session between myvolume and arbiternode.domain.tld::myvolume-geo does not exist.
>>> geo-replication command failed
>>> I also tried with "force" but no luck here either:
>>> $ sudo gluster volume geo-replication myvolume gfs1geo.domain.tld::myvolume-geo delete force
>>> Usage: volume geo-replication [<VOLNAME>] [<SLAVE-URL>] {create [[ssh-port n] [[no-verify]|[push-pem]]] [force]|start [force]|stop [force]|pause [force]|resume [force]|config|status [detail]|delete [reset-sync-time]} [options...]
>>> So how can I delete my geo-replication session manually?
>>> Mind that I do not want to reset-sync-time, I would like to delete it and re-create it so that it continues to geo replicate where it left from.
>>> Thanks,
>>> M.
>> _______________________________________________
>> Gluster-users mailing list
>> Gluster-users at gluster.org
>> http://lists.gluster.org/mailman/listinfo/gluster-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gluster.org/pipermail/gluster-users/attachments/20170808/bcdd7a14/attachment.html>

More information about the Gluster-users mailing list