[Gluster-users] auth.allow doesn't seem to work

Kevin Lemonnier lemonnierk at ulrar.net
Fri Sep 23 14:33:45 UTC 2016

> It looks like for NFS you have to change nfs.rpc-auth-allow, not auth.allow (which is for access by API). Docs for nfs.rpc-auth-allow states that "By default, all clients are disallowed", but in fact the option has "all" as default value.

Yeah but I tried both NFS and Fuse, both worked (fuse couldn't succeded at the end because it wasn't on the same network as the other nodes, but that's something else).
Looks like auth.allow just doesn't do anything. I wonder if it's because it saw the reverse instead of the IP.

In any case as I was saying I ended up blocking everything with iptables, that works for this cluster but doesn't for others,
so that's not a good fix for me. I wish I could just tell gluster to bind on a specific IP.

Kevin Lemonnier
PGP Fingerprint : 89A5 2283 04A0 E6E9 0111
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: Digital signature
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20160923/3c7ac062/attachment.sig>

More information about the Gluster-users mailing list