[Gluster-users] NFS ganesha client not showing files after crash

Jiffin Tony Thottan jthottan at redhat.com
Sun May 29 17:46:49 UTC 2016

On 28/05/16 08:07, Alan Hartless wrote:
> I had everything working well when I had a complete melt down :-) Well 
> got all that sorted and everything back up and running or so I 
> thought. Now NFS ganesha is not showing any existing files but the 
> root level of the brick. It's empty for all subdirectories. New files 
> or directories added show up as well. Everything shows up when using 
> the fuse client.

If I understand your issue correctly
* You have created a volume using brick which contains pre existing file 
and directories
* When you tried to access  the files via ganesha, it does not show up. 
But with fuse it is visible.

Can please try to perform force lookup on the directories/files(ls <path 
to directory/file>) from the ganesha mount?
Also check the ganesha logs (/var/log/ganesha.log and 
/var/log/ganesha-gfapi.log) for clues.
IMO there was similar issue exists for older version of ganesha(v2.1 I 
guess). if possible can you also share
the ganesha configuration for that volume

> I've tried self healing, editing files, etc but the issue persists. If 
> I move the folders and back, they show up. But I have a live setup and 
> can't afford the time to move GBs of data to a new location and back. 
> Is there anything I can do to trigger something for the files to show 
> up in NFS again without having to move directories?
> Thanks,
> Alan
> _______________________________________________
> Gluster-users mailing list
> Gluster-users at gluster.org
> http://www.gluster.org/mailman/listinfo/gluster-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20160529/76811496/attachment.html>

More information about the Gluster-users mailing list