[Gluster-users] Status in Peer Rejected

Luciano Facchinelli facchinelli.luciano at gmail.com
Thu Jan 14 22:01:12 UTC 2016

Hi guys !

I have a Gluster Volume (formed by 4 nodes with 1 brick each in
distributed-replicated mode).

A few months ago, one of those nodes went down and we replaced with a new
brick , after following this procedure [1] everything seems to be alright
again, but today i realized that this "new" node wasn't replicating the
info properly

Gluster-server5 (distribute)
Gluster-server4 (replica of Gluster-server5)
Gluster-server3 (distribute)
Gluster-server2 (replica of Gluster-server5) <---- This node was replaced
by a new one (fresh install

This new node was installed with the same version of OS (ubuntu server
The "old" nodes have Glusterfs 3.4.0, this new one has 3.4.*7 *

If I run "gluster peer status" from Gluster-server5 and Gluster-server4 :

Hostname: gluster-server2
Uuid: 6a25bf23-5909-4fc4-ab76-748eb84e7306
*State: Sent and Received peer request (Connected)*

If I run "gluster peer status" from Gluster-server3  :

Hostname: gluster-server2
Uuid: 6a25bf23-5909-4fc4-ab76-748eb84e7306
*State: Peer Rejected (Connected)*

And log file in the new brick says :


Seems like I'm having some mismatch problem with node 3 and node 2 (the new
node), but how can i solve it ?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20160114/5081aa4c/attachment.html>

More information about the Gluster-users mailing list