[Gluster-users] Using LIO with Gluster

Prasanna Kalever pkalever at redhat.com
Thu Aug 11 06:17:12 UTC 2016

On Fri, Aug 5, 2016 at 2:53 PM, luca giacomelli
<giacomelli.luca at gmail.com> wrote:
> Hi, I'm trying to implement something similar to
> http://blog.gluster.org/2016/04/using-lio-with-gluster/ and
> https://pkalever.wordpress.com/2016/06/29/non-shared-persistent-gluster-storage-with-kubernetes/
> Gluster 3.8.1 and Fedora 24
> gluster is up and running. The initiator discover the target but is not able
> to find the disk. I successfully tested targetli fileio with the same
> target and initiator.

Hey Luca,

Can you attach your /etc/target/saveconfig.json here ?
I doubt the targetcli configuration

Before that quick checks you can do:
* mount the gluster volume and see the target file exist
* targetcli /backstores/user:glfs/glfsLUN info

If you notice the correct signs above, try restarting the
tcmu-runner.service and target.service.

I remember there was a similar situation for me, nothing above worked,
I have rebooted the target nodes and flushed the iptables then it


> I tried also with tcmu-runner 1.1.0
> Any help would be appreciated.
> Thanks, Luca
> _______________________________________________
> Gluster-users mailing list
> Gluster-users at gluster.org
> http://www.gluster.org/mailman/listinfo/gluster-users

More information about the Gluster-users mailing list