[Gluster-users] FUSE incompatible on RHGS with centos/ubuntu open source clients?

Gluster Admin gluster at hepcat.org
Thu Sep 24 15:13:21 UTC 2015

Another update, after playing with our Oracle Enterprise Linux servers and
still not having luck I noted two things:

1) OEL 6 in Redhat Kernel works fine with 3.7.2 gluster fuse to RHS 3.1
2) OEL 6.6 UEK kernel does not work at all with 3.8.13-16 which is
installed by default.  I updated to latest UEK kernel below and now gluster
fuse mounts to RHS 3.1 and Open Source Gluster 3.7.x work well


[root at localhost ~]# uname -a
Linux localhost.localdomain 3.8.13-98.2.2.el6uek.x86_64 #2 SMP Tue Sep 15
16:20:45 PDT 2015 x86_64 x86_64 x86_64 GNU/Linux

On Wed, Sep 23, 2015 at 10:40 AM, Gluster Admin <gluster at hepcat.org> wrote:

> Just curious here if RH is purposely trying to prevent anyone but RHEL
> servers using their storage natively via the FUSE client?
> with RHGS 3.1 I can mount via fuse with no issues on RHEL 6/7 clients but
> no other variant of Gluster 3.6 or 3.7 client can connect to it.  Even
> tried installing the RHGS fuse and client libs with no success.  Same if i
> try to mount Gluster 3.7 from RHEL with FUSE so its both ways.
> Just a bummer as we have tons of non RHEL clients and would prefer not to
> setup NFS HA when the native client performs pretty well and covers all the
> HA without the hassle.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20150924/c2de1fd0/attachment.html>

More information about the Gluster-users mailing list