[Gluster-users] "gluster v heal info split-brain" show solved split-brain

Игорь Бирюлин biryulini at gmail.com
Wed Sep 9 10:17:49 UTC 2015

Hello all.
Today I had got a split brain on 2 node replica set installation.
I have solved problem by removing files from bricks.
find /storage/gluster_brick_repo -samefile
-delete -print
But in output of "gluster v heal repofiles info split-brain" I still see
removed file.
How can I remove it from output of this command?

More information:
[13:02:04] root at dist-master01:/ # cat /etc/issue
Ubuntu 12.04.5 LTS \n \l

[13:02:07] root at dist-master01:/ # dpkg -l | grep glusterfs
ii  glusterfs-client                     3.6.4-7
clustered file-system (client package)
ii  glusterfs-common                     3.6.4-7
GlusterFS common libraries and translator modules
ii  glusterfs-server                     3.6.4-7
clustered file-system (server package)

[13:02:13] root at dist-master01:/ # gluster volume info

 Volume Name: repofiles
 Type: Replicate
 Volume ID: ae71fb65-d477-492b-9701-cec2a6986759
 Status: Started
 Number of Bricks: 1 x 2 = 2
 Transport-type: tcp
 Brick1: xxx.xxx.xxx.xxx:/storage/gluster_brick_repo
 Brick2: yyy.yyy.yyy.yyy:/storage/gluster_brick_repo
 Options Reconfigured:
 cluster.data-self-heal-algorithm: diff
 cluster.self-heal-window-size: 2
 cluster.background-self-heal-count: 10
 server.allow-insecure: on
 performance.quick-read: on
 performance.cache-size: 6442450944
 performance.io-thread-count: 48
 performance.stat-prefetch: on
 performance.write-behind-window-size: 4MB
 performance.read-ahead: on
 nfs.disable: on

 [13:02:45] root at dist-master01:/ # gluster v heal repofiles info
 Brick dist-master01.xxx:/storage/gluster_brick_repo/
 Number of entries: 0

 Brick dist-master02.xxx:/storage/gluster_brick_repo/
 Number of entries: 0

 [13:03:19] root at dist-master01:/ # gluster v heal repofiles info split-brain
 Gathering list of split brain entries on volume repofiles has been

 Brick xxx.xxx.xxx.xxx:/storage/gluster_brick_repo
 Number of entries: 8
 at                    path on brick
 2015-09-09 02:17:33 <gfid:f7bdbdab-8dda-498f-ab03-6dcdfa2ed435>
 2015-09-09 02:18:34 <gfid:f7bdbdab-8dda-498f-ab03-6dcdfa2ed435>
 2015-09-09 02:19:35 <gfid:f7bdbdab-8dda-498f-ab03-6dcdfa2ed435>
 2015-09-09 02:20:36 <gfid:f7bdbdab-8dda-498f-ab03-6dcdfa2ed435>
 2015-09-09 02:21:37 <gfid:f7bdbdab-8dda-498f-ab03-6dcdfa2ed435>
 2015-09-09 02:22:38 <gfid:f7bdbdab-8dda-498f-ab03-6dcdfa2ed435>
 2015-09-09 02:23:39 <gfid:f7bdbdab-8dda-498f-ab03-6dcdfa2ed435>
 2015-09-09 02:24:40 <gfid:f7bdbdab-8dda-498f-ab03-6dcdfa2ed435>

 Brick yyy.yyy.yyy.yyy:/storage/gluster_brick_repo
 Number of entries: 0

 [13:03:27] root at dist-master01:/ #

Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.gluster.org/pipermail/gluster-users/attachments/20150909/ba1d3565/attachment.html>

More information about the Gluster-users mailing list