[Gluster-users] poor performance with encryption and SSL enabled

Jeff Darcy jdarcy at redhat.com
Tue Feb 24 17:33:34 UTC 2015

> SSL certs are self-signed and generated on all servers. Combined into a
> glusterfs.ca in /etc/ssl. By itself the SSL is working well.

Glad to hear it.  ;)

> If I run dd or any i/o operations I see a flurry of these messages in the
> logs.
> [2015-02-24 16:58:51.144099] W [stripe.c:5288:stripe_internal_getxattr_cbk]
> (--> /usr/lib64/libglusterfs.so.0(_gf_log_callingfn+0x1e0)[0x3fd0620550]
> (-->
> /usr/lib64/glusterfs/3.6.2/xlator/cluster/stripe.so(stripe_internal_getxattr_cbk+0x36a)[0x7f6a152a12ba]
> (-->
> /usr/lib64/glusterfs/3.6.2/xlator/protocol/client.so(client3_3_fgetxattr_cbk+0x174)[0x7f6a154db284]
> (--> /usr/lib64/libgfrpc.so.0(rpc_clnt_handle_reply+0xa5)[0x3fd0e0ea75] (-->
> /usr/lib64/libgfrpc.so.0(rpc_clnt_notify+0x142)[0x3fd0e0ff02] )))))
> 0-data-stripe-3: invalid argument: frame->local

Have you tried encryption (at rest) without striping, or vice versa?  I
suspect some kind of bad interaction between the two, but before we go
down that path it would be nice to make sure they're working separately.

More information about the Gluster-users mailing list