[Gluster-users] [Bug 1057645] ownership of diskimage changes during livemigration, livemigration with kvm/libvirt fails

Adam Huffman adam.huffman at gmail.com
Tue Feb 18 13:59:10 UTC 2014

Hi Paul,

Could you keep the list updated? That bug has been marked private, so
I can't see it.

Best Wishes,

On Tue, Jan 28, 2014 at 9:29 AM, Paul Boven <boven at jive.nl> wrote:
> Hi Bernhard, everyone,
> The same problem has now been reproduced on RedHat, please see:
> https://bugzilla.redhat.com/show_bug.cgi?id=1058032
> With 3.4.0 and Ubuntu 13.04, live migrations worked fine. For me it broke
> when the packages were upgraded to 3.4.1.
> I've set AppArmor to 'complain' as part of the debugging, so that's not the
> issue.
> I'm still not convinced that the file ownership itself is the root cause of
> this issue, it could well be just a symptom. Libvirt/qemu is perfectly happy
> to start a VM when its image file is owned root:root, and change ownership
> to libvirt-qemu:kvm. So I see no reason why it couldn't do the same during a
> live migration.
> In my opinion the real issue is the failure at the fuse level, that makes
> file access to the image on the destination impossible, even for root.
> Regards, Paul Boven.
> On 01/27/2014 07:51 PM, BGM wrote:
>> Hi Paul & all
>> I'm really keen on getting this solved,
>> right now it's a nasty show stopper.
>> I could try different gluster versions,
>> as long as I can get the .debs for it,
>> wouldn't want to start compiling
>> (although.... does a config option have changed on package build?)
>> you reported that 3.4.0 on ubuntu 13.04 was working, right?
>> code diff, config options for package build.
>> Another approach: can anyone verify or falsify
>> https://bugzilla.redhat.com/show_bug.cgi?id=1057645
>> on another distro than ubuntu/debian?
>> thinking of it... could it be an apparmor interference?
>> I had fun with apparmor and mysql on ubuntu 12.04 once...
>> will have a look at that tomorrow.
>> As mentioned before, a straight drbd/ocfs2 works (with only 1/4 speed
>> and the pain of maintenance) so AFAIK I have to blame the ownership change
>> on gluster, not on an issue with my general setup....
>> best regards
>> Bernhard
> --
> Paul Boven <boven at jive.nl> +31 (0)521-596547
> Unix/Linux/Networking specialist
> Joint Institute for VLBI in Europe - www.jive.nl
> VLBI - It's a fringe science
> _______________________________________________
> Gluster-users mailing list
> Gluster-users at gluster.org
> http://supercolony.gluster.org/mailman/listinfo/gluster-users

More information about the Gluster-users mailing list