[Gluster-users] Replace Brick fails (gluster 3.2.5) SOLVED

Heiko Schröter schroete at iup.physik.uni-bremen.de
Mon Dec 1 14:34:28 UTC 2014

well, not really solved but working. Knocking on wood ....
Recompiled glibc. Now the "gluster replace-brick" is working, BUT:

1) gluster volume replace ... start -> FAILED -> But processes are doing 
the replacement.
2) gluster volume replace ... status -> STATUS UNKNOWN

So till now there are two processes on the SOURCE and DEST brick doing 
the replacement data exchange in the background.

It seems to me that the underlying REPLACE-BRICK algorithm is working 
but the exchange of messages is severly broken.

Still have theses error messages when requesting the status:
[2014-12-01 15:24:13.188401] W [rpc-common.c:38:xdr_serialize_generic] 
[0x7f3ece4b0576]))) 0-xdr: XDR encoding failed
[2014-12-01 15:24:13.188409] E 
[glusterd-utils.c:404:glusterd_serialize_reply] 0-: Failed to encode message
[2014-12-01 15:24:13.188415] E 
[glusterd-utils.c:446:glusterd_submit_reply] 0-: Failed to serialize reply
[2014-12-01 15:24:13.189293] W 
[socket.c:1494:__socket_proto_state_machine] 0-socket.management: 
reading from socket failed. Error (Transport endpoint is not connected), 
peer (

I don't know if new versions of gluster do rely silently on some default 
settings on the bricks, but it should be checked during runtime/startup 
and marked in the logs. That would help a lot.

Thanks a lot and regards.

More information about the Gluster-users mailing list