[Gluster-users] libgfapi failover problem on replica bricks

Roman romeo.r at gmail.com
Mon Aug 4 10:03:28 UTC 2014


Facing the same problem as mentioned here:


my set up is up and running, so i'm ready to help you back with feedback.

proxmox server as client
2 gluster physical  servers

server side and client side both running atm 3.4.4 glusterfs from gluster

the problem is:

1. craeted replica bricks.
2. mounted in proxmox (tried both promox ways: via GUI and fstab (with
backup volume line), btw while mounting via fstab I'm unable to launch a VM
without cache, meanwhile direct-io-mode is enabled in fstab line)
3. installed VM
4. bring one volume down - ok
5. bringing up, waiting for sync is done.
6. bring other volume down - getting IO errors on VM guest and not able to
restore the VM after I reset the VM via host. It says (no bootable media).
After I shut it down (forced) and bring back up, it boots.

Need help. Tried 3.4.3, 3.4.4.
Still missing pkg-s for 3.4.5 for debian and 3.5.2 (3.5.1 always gives a
healing error for some reason)

Best regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20140804/8eae2088/attachment.html>

More information about the Gluster-users mailing list