[Gluster-users] Gluster 3.4 QEMU and Permission Denied Errors

Andrew Niemantsverdriet andrew at rocky.edu
Tue Sep 17 13:59:16 UTC 2013

Right now I am just using virsh to start the machines, I have also
tried using Virtual Machine Manager to start them.

I have enabled Gluster mounting from insecure ports, forgot to mention
that in my first email. It looks like the disk mounts as it starts to
boot but nothing can be written to the disk as it just hangs in an
infinite loop.

/-\ ndrew

On Tue, Sep 17, 2013 at 1:05 AM, Samuli Heinonen <samppah at neutraali.net> wrote:
> Hello Andrew,
> How are you booting/managing VM's? Which user you use to launch them?
> Have you enabled Gluster mounting from insecure ports? It needs two changes.
> You have to edit glusterd.vol (in /etc/glusterfs directory) and add line
> "option rpc-auth-allow-insecure on". Also you have to set volume option
> server.allow-insecure on (ie. gluster volume set volname
> server.allow-insecure on). Restart of glusterd and stop and start of the
> volume is required for these changes to take effect.
> 16.9.2013 21:38, Andrew Niemantsverdriet kirjoitti:
>> Hey List,
>> I'm trying to test out using Gluster 3.4 for virtual machine disks. My
>> enviroment consists of two Fedora 19 hosts with gluster and qemu/kvm
>> installed.
>> I have a single volume on gluster called vmdata that contains my qcow2
>> formated image created like this:
>> qemu-img create -f qcow2 gluster://localhost/vmdata/test1.qcow 8G
>> I'm able to boot my created virtual machine but in the logs I see this:
>> [2013-09-16 15:16:04.471205] E [addr.c:152:gf_auth] 0-auth/addr:
>> client is bound to port 46021 which is not privileged
>> [2013-09-16 15:16:04.471277] I
>> [server-handshake.c:567:server_setvolume] 0-vmdata-server: accepted
>> client from
>> gluster1.local-1061-2013/09/16-15:16:04:441166-vmdata-client-1-0
>> (version: 3.4.0)[2013-09-16 15:16:04.488000] I
>> [server-rpc-fops.c:1572:server_open_cbk] 0-vmdata-server: 18: OPEN
>> /test1.qcow (6b63a78b-7d5c-4195-a172-5bb6ed1e7dac) ==> (Permission
>> denied)
>> I have turned off SELinux to be sure that isn't in the way. When I
>> look at the permissions on the file using ls -l I see the file is set
>> to 600, this doesn't seem right. I tried manually changing the
>> permission to 755 as a test and as soon as the machine booted it was
>> changed back to 600.
>> Any hints as to what is going on and how to get the disk functioning?
>> The machine will boot but as soon as anything is written to disk it
>> will hang forever.
>> Thanks,

/-\ ndrew Niemantsverdriet
Linux System Administrator
Academic Computing
(406) 238-7360
Rocky Mountain College
1511 Poly Dr.
Billings MT, 59102

More information about the Gluster-users mailing list