[Gluster-users] failed to get the port number for remote subvolume -

Chitra Kalle crentala at gmail.com
Thu Oct 17 03:35:44 UTC 2013

I set up a Distributed replicated volume with 3 nodes each with 3 bricks.
However, the bricks are not online even after running the gluster volume
start and start force command.

Status of volume: testvol
Gluster process Port Online Pid
Brick 1xx.xxx.xx.202:/export/sda1/brick 24009 N N/A
Brick 1xx.xxx.xx.203:/export/sda1/brick 24009 N N/A
Brick 1xx.xxx.xx.204:/export/sda1/brick 24009 N N/A
Brick 1xx.xxx.xx.202:/export/sdb1/brick 24010 N N/A
Brick 1xx.xxx.xx.203:/export/sdb1/brick 24010 N N/A
Brick 1xx.xxx.xx.204:/export/sdb1/brick 24010 N N/A
NFS Server on localhost 38467 Y 9344
Self-heal Daemon on localhost N/A Y 9350
NFS Server on 38467 Y 1313
Self-heal Daemon on N/A Y 1319
NFS Server on 38467 Y 2687
Self-heal Daemon on N/A Y 2693

When I run the following I see the ports for the subvolumes on the server

netstat --tcp --listening --programs
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
    PID/Program name
tcp        0      0 *:38465                 *:*                     LISTEN
tcp        0      0 *:38466                 *:*                     LISTEN
tcp        0      0 *:38467                 *:*                     LISTEN
tcp        0      0 *:24007                 *:*                     LISTEN

Please help. What am I missing here? Tried to google for answers and did
not get any useful pointers.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20131016/f5a2a5d4/attachment.html>

More information about the Gluster-users mailing list