[Gluster-users] Error while trying to start glusterd

Chitra Kalle crentala at gmail.com
Tue Oct 15 20:32:43 UTC 2013


Ubuntu machines running Linux 2.6. Glusterfs version 3.3.2

I built glusterfs on one machine with --prefix, --with-mountutildir
--with-utildir --localstatedir options for configure.
Ran make and make install.

Then I copied the respective files/folders into the target machine's
/usr/local /etc/init.d and /sbin accordingly.

glusterfs runs fine on the build machine.

However, I get this error when I run it on the target machine using
/etc/init.d/glusterd start.

C [glusterfsd.c:1224:parse_cmdline] 0-glusterfs: ERROR: parsing the volfile
failed (No such file or directory)

/etc/init.d/glusterd status
 * glusterd service is not running.

Additional steps taken before I tried to start glusterd on the target
I modified the /etc/init.d/glusterd script to point to /usr/local
Added /usr/local/lib to /etc/ld.so.conf and ran ldconfig.

Any pointers appreciated. I am a newbie!

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20131015/c496ccbf/attachment.html>

More information about the Gluster-users mailing list