[Gluster-users] Fwd: bug in 3.4.1 when creating symlinks

Anand Avati avati at gluster.org
Wed Nov 13 20:24:46 UTC 2013

On Wed, Nov 13, 2013 at 12:14 PM, Peter Drake <peter.drake at acquia.com>wrote:

> Thanks for taking the time to look at this and reply.  To clarify, the
> script that was running and created the log entries is an internal tool
> which does lots of other, unrelated things, but the part that caused the
> error takes actions very similar to the gist.  I tried to pull out the
> related log entries to the best of my ability.  The script in the gist did
> not create those log entries, but it does reliably reproduce the same error
> / failure (failure when attempting to create a symlink from the local
> filesystem to a symlink on the gluster filesystem).  I would not be
> surprised if the PHP version of symlink has behavior that is different than
> the symlink syscall.
So what is the failure (errno) when creating a symlink from local fs to
glusterfs? Can you get an strace of the script when the error happens?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20131113/fa3300de/attachment.html>

More information about the Gluster-users mailing list