[Gluster-users] glusterfs missing files on ls

Vijay Bellur vbellur at redhat.com
Sun Jun 2 05:52:03 UTC 2013

On 05/31/2013 03:18 PM, Stefano Sinigardi wrote:
> Dear Xavier,
> I realized that the volume was not build properly when doing the first
> analyses suggested by Davide, but I'm sure that this is not the problem
> and so I quickly dismissed it. Also, we need a replica but not so
> strictly, maybe in the future with the next volume I'll build it
> properly. Anyway, yes, the volume got birth on "pedrillo" with a
> replica-2 and the next day was expanded on "osmino", again with
> replica-2, just by adding bricks and doing a rebalance, that was just
> tried. I'm saying "tried" because it got "stuck", consuming a lot of RAM
> (almost all, 16 GB), and it was counting million of files that I think
> don't even exist on the volume, so I stopped it. Do you think that it
> might be worth restarting?

I might have missed this detail in the thread. What is the disk 
filesystem on the bricks?

Can you list the exact rebalance command that was triggered?


More information about the Gluster-users mailing list