[Gluster-users] gluster no longer serving all of its files

Pat Haley phaley at MIT.EDU
Fri Jan 27 15:49:07 UTC 2012


We recently upgraded our version of gluster from 3.1.4 to
3.2.5. Shortly after I noticed that gluster was not serving
up all of its files, that is if I log onto one of the individual
bricks and do an ls of the underlying nfs directories, I can
see files that I do not see if do an ls from a client node
in the equivalent gluster directory.

We may have caused this by also running a script that went
through and removed pointer files (this had been how we had
been dealing with bad pointers under gluster 3.1.4).

So far, we have tried running a gluster self-heal under
version 3.2.5 which did not solve the problem.  We have
also tried rolling back to version 3.1.4 and running the
self-heal there, but that does not solve the problem either.

Any advice you can give us would be greatly appreciated.

Pat Haley                          Email:  phaley at mit.edu
Center for Ocean Engineering       Phone:  (617) 253-6824
Dept. of Mechanical Engineering    Fax:    (617) 253-8125
MIT, Room 5-222B                   http://web.mit.edu/phaley/www/
77 Massachusetts Avenue
Cambridge, MA  02139-4301

More information about the Gluster-users mailing list