[Gluster-users] unable to access volume integrated for RDMA through NFS mount

Neetu Ojha neetuojha.cdac at gmail.com
Mon Sep 5 11:54:08 UTC 2011

Dear Team,

 Earlier also i have put a mail regarding this same issue. I have installed
glusterfs 3.2.2 on linux 64 bit in replication mode.
 The volume is created with RDMA protocol and for test purpose i have done a
nfs mount and glusterfs mount on two machines. The machine where the
glusterfs mount is done from there setfacl works and any secondary user is
able do all read write under mount point. Whereas on nfs mount client
setfacl is not working it throws error setfacl .. : operation not supported,
so no user other then root can access the volume on nfs client.

Then I got one relevant solution from gluster-user that we may need to
disable gluster nfs . When i tried it shows like :
gluster volume set test-volume-infi nfs.disable on
:operation failed
The same error was generated after and before stopping gluster daemon.

I am quite keen to know that if volume is created with RDMA protocol can we
really do nfs mount for client, if it is possible then what am i missing. As
i have even updated /etc/exports but still setfacl not working. how
secondary users can access the volume mounted with nfs. The care has been
taken to mount at both server and client with acl option.

 Neetu Sharma
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20110905/aa0357d6/attachment.html>

More information about the Gluster-users mailing list