[Gluster-users] add brick fails

mkey mkey at inter7.jp
Mon May 16 18:17:39 UTC 2011

I am trying to use tried to glusterfs_3.2.0 on ubuntu natty(11.04).
I have 3 servers, and 2 servers are already added to peer by following
> root at natty3:~# gluster peer probe natty3
> root at natty3:~# gluster peer probe natty4

also, I created volume.
> root at natty3:~# gluster volume create test-volume transport tcp
natty3:/opt/gluster/distributed natty3:/opt/gluster/distributed
> root at natty3:~# gluster volume info
> Volume Name: test-volume
> Type: Distribute
> Status: Created
> Number of Bricks: 2
> Transport-type: tcp
> Bricks:
> Brick1: natty4:/opt/gluster/distributed
> Brick2: natty3:/opt/gluster/distributed

but when I tried to add brick, it failed.
> root at natty3:~# gluster peer probe natty2
> root at natty3:~# gluster volume add-brick test-volume
> Another operation is in progress, please retry after some time

/var/log/glusterfs/etc-glusterfs-glusterd.vol.log said
>[2011-05-13 09:42:29.77565] E
[glusterd-handler.c:1288:glusterd_handle_add_brick] 0-: Unable to set
cli op: 16
> [2011-05-13 09:42:29.82016] W
[socket.c:1494:__socket_proto_state_machine] 0-socket.management:
reading from socket failed. Error (Transport endpoint is not connected),
peer (

/var/log/glusterfs/cli.log said
> [2011-05-13 09:43:28.135429] W
[rpc-transport.c:604:rpc_transport_load] 0-rpc-transport: missing
'option transport-type'. defaulting to "socket"
> [2011-05-13 09:43:28.221217] I
[cli-rpc-ops.c:1010:gf_cli3_1_add_brick_cbk] 0-cli: Received resp to add
> [2011-05-13 09:43:28.221348] I [input.c:46:cli_batch] 0-: Exiting with: -1

Mounting volume is OK because if I tried to mount test-volume from
natty3 natty4, and created some files, then I can see them from both
hosts. In addition, probing natty2(new server) is OK because "gluster
peer status" lists natty2.

I have no idea how to get over this.
Any helps are appreciated.


More information about the Gluster-users mailing list