[Gluster-users] error writing to gluster-fs over fuse

William M Bradley billb at uab.edu
Wed Jun 15 19:37:17 UTC 2011

I ran into an error while trying to push into a git repo on gluster storage.

error: unable to resolve reference refs/heads/master: Invalid argument
remote: error: failed to lock refs/heads/master
To /research/rcs/git/docsbuild.git
 ! [remote rejected] master -> master (failed to lock)
error: failed to push some refs to '/research/rcs/git/docsbuild.git'

I thought this was due to some messed up history in my git repoand so I tried to remove the repo on gluster-fs mounted research storage and start anew, for which I got the following error:

rm -rf docsbuild.git/

rm: cannot remove `docsbuild.git//refs/heads/master': Invalid argument

I then changed to storage mounted over nfs and was able to remove the directory there.

$ pushd /research-nfs/rcs/git
 $ ls
blogsbuild.git  blogs.git  builddocs.git  docsbuild.git  docs.git  mediawiki-deploy.git  mediawiki.git  wordpress.git
$ rm -rf docsbuild.git/
$ ls
blogsbuild.git  blogs.git  builddocs.git  docs.git  mediawiki-deploy.git  mediawiki.git  wordpress.git

Any ideas as to why the fuse mounted gluster would run into a locking issue with git?

Bill Bradley
Systems Engineer III
Infrastructure Services - Unix
billb at uab.edu<mailto:billb at uab.edu>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20110615/e9ff5442/attachment.html>

More information about the Gluster-users mailing list