[Gluster-users] Almost no performance on Gluster 3.05 and Citrix XenServer

Erwin Lubbers erwin at lubbers.org
Fri Jan 14 15:51:42 UTC 2011


I'm testing a Gluster Storage Platform version 3.05. and a Citrix XenServer. I did a clean setup of the Gluster platform on a dual core 2 Ghz Xeon machine with 4 Gbyte memory 3 SATA disks of 750 Gbyte each. That did go smooth. Than I created a NFS VHD storage repository on XenServer and it also worked within seconds.

Then I added a 1 Gbyte disk to a virtual machine running CentOS 5. Did a fdisk without problems to partition it and then I try to format is with a ext3 filesystem. It took more then one hour to format that 1 Gbyte :-( 

I logged into the Gluster machine to see where the bottleneck is.

I don't see any ethernet errors (both the Gluster machine and XenServers are connected to the same switch using a 1 Gbps connection). Ping times between the XenServer, VM and Gluster are around 0.1 ms without loss.

I tried to create a large file with dd on the Gluster machine and that seems to perform as expected:

[gluster at storage01 ~]$ dd if=/dev/zero of=test bs=8k count=100000
100000+0 records in
100000+0 records out
819200000 bytes (819 MB) copied, 4.03408 s, 203 MB/s

Any suggestions on where to look?


More information about the Gluster-users mailing list