[Gluster-users] Problem using fixed-uid with glusterfs 3.1.4 (error says: fixed-uid does not exist???)

Cal Leeming [Simplicity Media Ltd] cal.leeming at simplicitymedialtd.co.uk
Mon Apr 18 15:44:11 UTC 2011

Hey all,

I've got a bit of a problem. I have a server (meisje) which hosts a
glusterfs volume, and another server (courtney) which mounts it. (Also
Annabelle, which does the same thing as courtney)

On courtney, I'm trying to mount the volume with a fixed UID/GID.

I've tried to do this via the mount options (uid=2000,gid=2000), but this

I've also tried to do this on the glusterfs server itself by using:

 root at meisje.simplicitymedialtd.co.uk [/mnt/encstore/simplicitymedialtd-ds]
> gluster volume set simplicitymedialtd-ds fixed-uid 20000
option : fixed-uid does not exist
Did you mean cache-size or disable?

The problem with using the second option, is that each server which is
mounting the directory, will need a different UID/GID (courtney needs
2000/2000, annabelle needs 2001/2001, etc etc).

Using NFS is an option, although I'd much prefer to use GlusterFS client

If anyone could give me a heads up, it'd be very much appreciated!


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://supercolony.gluster.org/pipermail/gluster-users/attachments/20110418/8a6bc098/attachment.html>

More information about the Gluster-users mailing list