[Gluster-users] init script problem

Craig Carl craig at gluster.com
Mon Sep 27 22:54:19 UTC 2010

Marcus - 
Can you file a bug at http://bugs.gluster.com? 



Craig Carl 

Sales Engineer; Gluster, Inc. 
Cell - ( 408) 829-9953 (California, USA) 
Office - ( 408) 770-1884 
Gtalk - craig.carl at gmail.com 
Twitter - @gluster 
Installing Gluster Storage Platform, the movie! 

From: "Marcus Bointon" <marcus at synchromedia.co.uk> 
To: "Gluster General Discussion List" <gluster-users at gluster.org> 
Sent: Monday, September 27, 2010 1:29:31 PM 
Subject: [Gluster-users] init script problem 

I just ran into an odd issue with the init script in 3.0.5. It uses LSB's pidofproc to see if there's already a server running, however, pidofproc uses the full path to the binary to ensure it's looking at the right one, however, since gluster server and client use the same binary (glusterfs is a symlink to glusterfsd), if it's running a client but not a server, it will erroneously return the pid of the client, report that a server instance is already running (though fail to find a pid), and thus prevent the server from starting. Looking at the docs for pidofproc, it's supposed to fail to return a pid if it doesn't find a pid file, however it wasn't in this case. 

I solved it by stopping the client, then the server started ok, then I remounted the client and it all worked. 

Gluster-users mailing list 
Gluster-users at gluster.org 

More information about the Gluster-users mailing list