[Gluster-users] replicating storage for ESX problem

Romans Ščugarevs admin at alfalinks.lv
Mon Feb 15 08:29:54 UTC 2010


Yes I've tried reexporting using unsfd too, but problem was the same.
What is even more interesting, when I'm trying to upload an iso image  
to the storage using ESXi interface, everything is fine(image size  
 >1GB) so no problem in creating large files.

Quoting "Raghavendra G" <raghavendra at gluster.com>:

> Hi Romans,
> Have you tried reexporting glusterfs using unfsd?
> regards,
> On Sun, Feb 14, 2010 at 5:02 PM, Romans Ščugarevs <admin at alfalinks.lv>wrote:
>> My configuration:
>> Two node(raid1) cluster based on glusterfs with NFS server.
>> The system is replicating nicely. Changes are synced. The storage is
>> exported over NFS for vmware esx usage.
>> The problem is when I am using vmware ESX to create a VM on the NSF
>> storage, the result is an empty unusable virtual disk. When I export some
>> local ext3 from one of the nodes, correct 8GB VM disk is created. When I
>> reexport the glusterfs mount, I 'm getting unusable VMs(almost zero size). I
>> suppose it has something to do with so called thin provisioning over NFS.
>> Any advice is appreciated!
>> Regards,
>> Roman.
>> _______________________________________________
>> Gluster-users mailing list
>> Gluster-users at gluster.org
>> http://gluster.org/cgi-bin/mailman/listinfo/gluster-users
> --
> Raghavendra G

More information about the Gluster-users mailing list