[Gluster-users] glusterfs 3.1.0 disable-io-mode

Raghavendra G raghavendra at gluster.com
Thu Dec 2 05:48:17 UTC 2010

Hi kostas,

You can track the progress of this bug at

Meanwhile you can disable direct-io-mode by directly starting glusterfs (instead of through mount command).

----- Original Message -----
From: "Kakaletris Kostas" <kkakas at yahoo.gr>
To: "Raghavendra G" <raghavendra at gluster.com>
Cc: gluster-users at gluster.org
Sent: Thursday, December 2, 2010 4:20:01 AM
Subject: Re: [Gluster-users] glusterfs 3.1.0 disable-io-mode

 From what i remember i tried and the following
mount -t glusterfs --direct-io-mode=off
mount -t glusterfs -o direct-io-mode=off
mount -t glusterfs --direct-io-mode=disable
mount -t glusterfs -o direct-io-mode=disable
mount -t glusterfs -o --direct-io-mode=disable
and others but didn't managed to solve the problem we had. Sorry but 
can't try it again to be 100% sure for the result of all the above since 
we removed gluster3.1.0 from theses 4 servers that we were testing :(
Maybe the problem was somewhere else to the systems (centos5.5) since 
3.0.5 that installed after that wasn't working right with xen and tap 
for disk files either, while 3.0.5 on debian servers is working just 
fine with xen and tap.
Probably has to do with the different kernel version as i mentioned to 
my previous mail (lenny has xen 2.6.26 and centos 2.6.18).
The other difference between the two setups was that on debian servers 
downloaded source and on centos servers downloaded the rpms for centos.
Thanks for your interest and your very nice software and sorry that 
can't give more details that maybe could help others too but as i wrote 
we removed from the centos (working fine on debian).
It's a bit difficult time these days for more retries :( , so will try 
again but later on centos 6 and new xen kernel.

Thank you very much,

Στις 2/12/2010 1:43 πμ, ο/η Raghavendra G έγραψε:
> in 3.1.x the options --disable-direct-io-mode and --enable-direct-io-mode are replaced by --direct-io-mode=[off/on]. So, I was interested in knowing whether you used the option --disable-direct-io-mode or --direct-io-mode.> From your previous mail, it seems you are trying to use --disable-direct-io-mode (which is not supported in 3.1.x). Hence please use --direct-io-mode and let us know whether the issue still persists.
> regards,
> ----- Original Message -----
> From: "Kakaletris Kostas"<kkakas at yahoo.gr>
> To: "Raghavendra G"<raghavendra at gluster.com>
> Cc: gluster-users at gluster.org
> Sent: Wednesday, December 1, 2010 3:34:10 PM
> Subject: Re: [Gluster-users] glusterfs 3.1.0 disable-io-mode
> Hello,
> I remember that i tried that to with mount -t glusterfs and i was
> getting error that glustrerfs don't understand --disable-direct-io-mode
> (wasn't writing disable but probably was translating the command to that) .
> We removed gluster 3.1 and install gluster 3.0.5 from the centos rpms
> where the parameter gave no error but we continue having problems with
> xen and paravirtualized with tap "disks" . We installed the patched fuse
> and didn't solved our problem. We get to the conclusion that maybe
> problem was that the kernel on these machines was 2.6.18-194.el5xen
> (centos 5.5). On debian machines that xen  kernel was 2.6.26 was working
> with tap, but the machines we wanted to use are dell that debian is not
> installing. We gonna have a look for testing with other clustered file
> system on these machines and check again with glusterfs when we are
> going to install centos6 and make use of new glusterfs version.
> Thanks for your replies
> Kostas
> Στις 1/12/2010 8:23 πμ, ο/η Raghavendra G έγ�α�ε:
>> Hi Kostas,
>> Is --direct-io-mode=off not working for you?
>> regards,
>> Raghavendra.
>> ----- Original Message -----
>> From: "Kakaletris Kostas"<kkakas at yahoo.gr>
>> To: gluster-users at gluster.org
>> Sent: Tuesday, November 23, 2010 3:27:39 PM
>> Subject: [Gluster-users] glusterfs 3.1.0 disable-io-mode
>> Hello,
>> I'm trying gluster 3.1.0 in conjunction with XEN on centos 5.5.
>> I have problem installing a vm cause installation hangs. Searched the
>> net and found that for xen to work in previous gluster versions thay had
>> to disable direct io mode.
>> glusterfs says that don't recognize --disable-direct-io-mode. I tried
>> several syntax with --diasble-direct-io-mode , direct-io-mode=disable,
>> direct-io-mode=off , and in different positions of the mount command
>> (mount -t glusterfs -o<opt>   ......  , mount -o<xxx>   -t glusterfs
>> xxxx:/xxx /xxx , etc)
>> Thanks in advance
>> Kostas
>> _______________________________________________
>> Gluster-users mailing list
>> Gluster-users at gluster.org
>> http://gluster.org/cgi-bin/mailman/listinfo/gluster-users

More information about the Gluster-users mailing list