[Gluster-users] upgrade 2.0.2 to 2.0.9?

Count Zero countz at gmail.com
Sun Apr 18 16:31:52 UTC 2010

Make sure all your clients know about all your bricks, make sure the hostnames are correct, etc.
Make sure there's communications between the nodes, on the glusterfs prort.
And at worst, move the /data/export directory to /data/export.old and make a new /data/export
Remount on all servers, and run some tests (perhaps with bonnie++).

Once you are happy with the performance and functionality, move the files in /data/export.old/ back to /data/export by copying them over.

On Apr 18, 2010, at 9:25 AM, Robert Minvielle wrote:

> Yes, tried that. Same thing. 
> I thought I recalled that would fix it... but it seems to not
> work. 
> ----- "Count Zero" <countz at gmail.com> wrote:
>> If I remember correctly, the suggestion was to type: ls -lR
>> (You do this from your mounted directory).
>> In theory, this forces glusterfs to update/heal/etc.
>> Aric
>> On Apr 18, 2010, at 9:07 AM, Robert Minvielle wrote:
>>> I have two glusters, a production and test gluster. A while back, I
>> upgraded the
>>> test gluster from 2.0.2 to 2.0.9 with no problems. Both glusters are
>> running gentoo,
>>> same version, same kernel. The client saw all of the files,
>> everything worked.
>>> Over this weekend I upgraded the main production gluster, as we are
>> trying to get some
>>> more speed and I was told by the gluster team some time ago to try
>> out 2.0.9 to cure
>>> a few problems. I did the same exact upgrade that I did on the test
>> gluster.
>>> Now that I am done, I can mount it fine and I get no errors in the
>> logs, however,
>>> most (e.g. 85%) of my files are missing, or I get a "cannot access
>> /data/blah/blah no
>>> such file or directory". The files exist on the server in the
>> exported directory,
>>> but the client does not see some of them. I recall there was
>> something I had to do
>>> to fix this perhaps... I can not recall what it is.
>>> Anyone have any ideas? (other than shutting down work tomorrow,
>> ugh)
>>> At this time I may be forced to back off to 2.0.0... hope that works
>> :O
>>> _______________________________________________
>>> Gluster-users mailing list
>>> Gluster-users at gluster.org
>>> http://gluster.org/cgi-bin/mailman/listinfo/gluster-users

More information about the Gluster-users mailing list