[Gluster-users] The continuing story ...

Krishna Srinivas krishna at gluster.com
Thu Sep 17 22:00:08 UTC 2009

We have logged the bug at

You can track the progress there.

Basically, when backend FS hangs because of lockups further access to
that FS from the glusterfs mount point will return error (instead of


On Mon, Sep 7, 2009 at 8:16 PM, Stephan von Krawczynski
<skraw at ithnet.com> wrote:
> Hello all,
> last week we saw our first try to enable something like a real-world
> environment on glusterfs fail.
> Nevertheless we managed to get a working combination of _one_ server and _one_
> client (using a replicate setup with a missing second server).
> This setup worked for about 4 days, so yesterday we tried to enable the second
> server. Within minutes the first one crashed. Well, really we do not know if
> it crashed in its true meaning, the situation looked like this:
> - server was ping'able
> - glusterfsd was disconnected by the client because of missing ping-pong
> - no login possible
> - no fs action (no lights on the hd-stack)
> - no screen (was blank, stayed blank)
> This could also be a user-space hang or cpu busy/looping. We don't know.
> The really interesting part is that the server worked for days being single,
> but as soon as dual server fs action (obviously in combination with self
> healing) started it did not survive 10 minutes.
> Of course the second server went on, but we had to stop the whole thing
> because the data was not completely healed, so it made no sense to go on with
> old copies.
> This was glusterfs 2.0.6 with a minimal server setup (storage/posix,
> features/locks, performance/io-threads) on a linux kernel
> Is there someone out there that experienced something the like?
> Any ideas?
> --
> Regards,
> Stephan
> _______________________________________________
> Gluster-users mailing list
> Gluster-users at gluster.org
> http://gluster.org/cgi-bin/mailman/listinfo/gluster-users

More information about the Gluster-users mailing list