[Gluster-users] Replication not working on server hang

Jeff Evans jeffe at tricab.com
Tue Sep 1 02:06:35 UTC 2009

> we have no problem on using the volume for reading data and if
> the server is not under heavy load it works well for writing too,
> only hangs when server is using 100% cpu for math intensise
> calculations and we try to write a lot of data to glusterfs
> volume (it usually
> takes some hours for it to hang)

Interesting, as I suspect our hangs have occurred during very low CPU
utilization. Can't tell for sure, as we can't get a shell during the
>> Talk of XFS being stable is encouraging me to give it a shot.
> It will be very difficult for us to migrate everything to xfs
> now, but i will like to see someone having problems without xfs
> not having that problems with xfs rather than people not having
> problems saying that xfs is stable to start such large migration
> process

Agreed, that is exactly why I would like to try a different FS.
If I still get hangs under XFS, then at least I'll know the hangs are
almost certainly not due to EXT3 bugs.

If it does work, then I have sneaked around the problem, rather than
solved it (cheat!)

Fortunately, I don't have too much data right now, and I can devote a
 partition to XFS for testing. My systems are in 24x6 production
though, so I will need to wait for a quite (Sunday) period for the
real testing.

Thanks, Jeff.

More information about the Gluster-users mailing list