[Gluster-users] Exported NFS - written files are zero size

Bike & Snow bikeandsnow at googlemail.com
Wed May 13 08:29:04 UTC 2009

I was using kernel 2.6.28 on Ubuntu for the Gluster client, which in
turn acts as the NFS server.

I've tried kernel 2.6.30rc5 and NFS exports now work OK. I can now
write to the exported GlusterFS from an NFS client.

However, performance is not that great.

If I setup an NFS test using a *physical disk* in the machine, I can
obtain NFS *write* performance on a network client of 117.9 MB per

Using a GlusterFS as the exported filesystem, I get these results from
the NFS client:
Read: 109.3 MB per second
Write: 40.6 MB per second

So read performance is good but write performance is much lower
compared to exporting a physical disk. Around 33% of physical disk.

I have tried the write-behind translator on the Gluster client but it
makes no difference.

Running the disk benchmark directly on the GlusterFS on the Gluster
client gives me:
Read: 1502.2 MB per second
Write: 224.3 MB per second

So our write performance on the Gluster client should be more than up
to the job of allowing NFS clients to write at much more than 40.6 MB
per second.

Does anyone have any information on tuning a Gluster client for NFS exports?


More information about the Gluster-users mailing list